Visual Studio 2008 Slow In Design Mode

[Update: Download the hotfix for Visual Studio 2008 SP1 that fixes this issue here.]

Using the ASPxGridView in the Visual Studio 2008 ASPX markup is slower than it should be due to an issue in the Visual Studio 2008 Intellisense. We've reported it to Microsoft and they've sent us a preliminary fix for testing. Unfortunately, it's not released and I don't have an expected release date yet.

At the heart of the issue is the number of properties that are supported by any control in VS2008. If a control, like the ASPxGridView, is rich in properties then the Visual Studio 2008 Intellisence code slows downs and spikes the CPU. Unfortunately, there isn't a workaround yet but we hope Microsoft will release the aforementioned update soon.

The good news is that we've tested the possible fix and it works very well. We're still doing some internal testing to verify this fix but we're confident that it solves the issue.

Thanks and I'll post the link to the official release as soon as its made available.

Tags
62 comment(s)

Good to know,.

Thanks very much

18 January, 2008
Piero

I wonder why such a problem has passed the beta testing yours and Microsoft?

The IDE is not really usable.

18 January, 2008

That is good news.  Looking forward to the fix.

18 January, 2008

That is good news!

Thank you very much

18 January, 2008

Nice to read this info... (the fix for the issue).... but... bad to read that VS2008 has some issues like the mentioned. I'm waiting some months more to make the migration to VS2008.

Regards

18 January, 2008

Pingback from  » Daily Bits - January 19, 2008 (Early Edition) Alvin Ashcraft’s Daily Geek Bits: Daily links plus random ramblings about development, gadgets and raising rugrats.

18 January, 2008

Take a look at: forums.microsoft.com/.../showpost.aspx

We are all having the same issue when it comes to editing source of a webform,  Hope it gets fixed soon or we will be forced to revert back to vs 2005...

20 January, 2008

Thanks guys...

Its running like an absolute dog without the fix so fingers crossed M$ get it released soon!

20 January, 2008
Dean

I really need this fix

25 January, 2008

Good to hear a fix is coming.  Let's hope it's sooner than later....life is too short to deal with this sort of performance.

25 January, 2008
Jason

Please do all you can to expedite the solution from MS.  It clearly is an MS issue, but you most know that it makes you both (DX and MS) look bad.  As a customer, I cannot justify spending money an a product that doesnt work for me, regardless of who is at fault.  Thanks

28 January, 2008
Skippy Butternutty

Is it just me or is VS2008 a fat bloated pig? This thing takes longer to load than video games. 2MB of ram and it just churns and churns and churns, just to load small projects.

If it does require alot of loading, why doesn't MS put a dialog box up or some indication telling you what it is doing?

Hey MS, quit adding features and just optimize the code and give us better error handling and verbose notifications.

28 January, 2008
Robert

Hi,

Yeah...I have found that 2008 slows down more and more.  A quick re-start usually solves the issue.  Also, only keep one page with a grid view open at a time.  Be nice once the patch is out.

2008 Loads very fast on my vista machine...so I'd think it's just you Skippy (1.5GB of RAM AND running a web server / SQL server).

30 January, 2008

VS 2005 was bad as well.  2008 takes it to a new level of bad.

For whatever reason, installing the latest expressapp release helped.  Not sure why, but that was forum post, and it did help everything, even though I'm not using it in my app.

I also note that like VS2005, VS 2008 has memory leaking issues, the longer you run the slower things get until you reboot.

I am thinking that a dual quad core with 32 gb of ram and striped 15K SAS drives MIGHT make VS2008 useable.  Just need to sell a lot more work...

30 January, 2008
Crono

Funniest part is even though VS has a long history of malfunctioning, bugs and memory leaks... it still is an unavoidable tool, more helpful than restraining.

My thoughs on VS2008 is that it looks like 2005 on steroids. Some 2005 bugs seems to be gone by now, and apart from sluggish performance, I didn't notice any new major bug.

For that reason, I'm glad I migrated to 2008 already. I don't regret it a second.

Still, I understand and share the pain of many developpers here, and like them, I'm waiting for the next version of VS, asking myself "which bugs will be fixed by then?".

Ahhh, MS...

30 January, 2008
stoat100

Skippy: '2MB of ram and it just churns and churns and churns'

Maybe you need to pimp it up to 4Mb :)

7 February, 2008
Charles matvchuk

Any word on the patch as of yet ?

7 February, 2008
DM
8 February, 2008
John

Nice....

but the fix doesnt fix anything unfortunatly....

15 February, 2008
Bosse

Unfortunatly no... :(

15 February, 2008

After I reinstall Visual Studio 2008 and Hotfix, it also still insanely slow for me when ASPxGridView in my webform . I use DXperience 7.3.7 trial edition.

19 February, 2008

John, Bosse, & Jerry,

Please create a support ticket describing your exact environments, product versions, etc. and our team will look into it. Here is the link: www.devexpress.com/.../CreateIssue.aspx

Thanks.

19 February, 2008

I used an aspxgridview today, and discovered that my markup editing became slow. Searched and found this article. After installing the fix, markup typing is not hindered by any intellisense delays. Great!

17 March, 2008

Alright, my performance never came back after the fix.... But then I was trolling and found this, not exactly sure why it works like it does but Visual Studio 2008 is instant on rendering saving, toggleing views and working on the markup.

IE7

Tools->Internet Options->Advanced->Security section-> uncheck "check for publisher's certificate revocation.........  Fast VS 2008 again.

21 March, 2008

Thanks Charles,

Is this the post you're referring to? http://tinyurl.com/2txsso

I'm glad it worked for you, however, there is a warning about disabiling this option if the machine has internet access.

Thanks.

21 March, 2008

Yes that was the post.  On my dev machine I have done it and it works great.  Lesser of two evils imo.  1 minute toggle times between saves and views is draining the life out of me.

21 March, 2008

Aaaaaarrrrgggg! Does anybody know of any way to tweak the vs2008 IDE. I have a huge project to complete and the larger it gets the slower the IDE gets. I have tried everything I can think of the speed it but nothing. I am dying here :(

P.S. The rollup was a faust.

11 June, 2008

Hi Ross,

I feel your pain and I'm sorry to hear about the issues. There is a VS2008 SP1 coming out but not sure when. In the meantime, you may try Scott Guthrie's tips for speeding up VS2008: http://tinyurl.com/5h5vm4

11 June, 2008
Ross Glenn

Thanks Mehul for the reply. I have tried the SP1 Beta but to be honest I dont see any improvement in the actual performance of VS 2008. I installed VS 2005 again and compared the project in both versions. VS 2005  rocks compared to VS 2008 which confirms this has nothing to do with the third party controls. I have tried tweaking the IDE but as soon as i open the web form with the ASPxGridView I can go to lunch during the response times (largely over exaggerated of course but you get the picture).

Hope the final SP is completed soon.....

18 June, 2008

I'll second Ross's comments, to a degree. I tried installing VS.2008 SP1 Beta specifically to try to solve this issue, but it didn't seem to produce any improvement whatsoever.

However, that being said, VS.2008 seems to perform better in my situation than does VS.2005.

What frustrates me right now is that I'm unable to do anything practical to speed things up, and even though I've presented the problem to DX support, they don't have any practical suggestions either, other than tell me to reduce the size of the page (difficult to do with an ASPxPageControl).

Is there a way to press the issue with Microsoft more forcefully?

30 June, 2008

Just a quick note to tell you that we’ve been working Microsoft to find and solve some of the reported issues. Microsoft has been good at getting resources and also digging into some of the problems.

It’s too early to report the results but I’ll keep you posted once we have some more information. Stay tuned.

30 June, 2008
CW

Just having great fun dealing with Visual Studio 2008 even with the hotfix. I've come to the conclusion that MS must have given up performance testing or go through a user acceptance process.

What a complete pile of crap. It's about time MS got replaced their entire development team with individuals who have even the slighest concept of product quality.

Here's an idea rather than working round the clock to address serious issues, why not fix the issues before you release a product? Could it be that MS are entirely drivn by sales deadlines even if it screws the end user?

It's about time someone gave Steve B a kicking.

You name it, MS bloat it, from Vista now to Visual Studio.

I've upgraded my workstation to a quad core with 8gb of RAM and VS is still a dog.

8 July, 2008

I'm in the same boat.  Tried ScottGu's hotfix... am planning on install the SP1 beta now.  Have a production-SLN with 3 projects (typical DAL, BAL, UI separation)... and vs2008 is driving me crazy.   I hope to hear something soon!

14 July, 2008

It appears that Microsoft finally fixed the problem.  I just now downloaded and installed Microsoft Visual Studio 2008 Service Pack 1 Beta and my slowness problems vanished without making any settings changes suggested above.  Saving large ascx and aspx files happens almost instantly and switching between Source and Design views in VS 2008 happens without delay.  Previously, I was experiencing agonizing delays that got longer and longer as the page size grew.  I'm now happy to report that the Service Pack 1 Beta has fixed the problem for me.

16 July, 2008
KK

Darryl...Don't know what planet with futuristic lightspeed technology you're living on...

Installed the HotFix, nothing changed....watching the HTML Designer follow my keyboard strokes is more painful than watching paint dry!

Uninstalled the HotFix, Installed SP1 Beta instead...no dice...Now I'd just rather eat glass....

P4 2.8, 3GB Ram, Vista Ult

(Only reason I use Vista is for IIS7 compatability...else I'd be full time on XP).

18 July, 2008

We just installed the lastest release of SP1 for VS 2008 and this had a definite improvement in the performance of this feature.  We were concerned this would not help based on the posts we have seen but it did have a big improvement for us.  We are still testing with this, but this look like it is a good fix for this right now.

6 August, 2008

I still facing performance slow in VS 2008 even though I have install SP1. Any ideas?

Thank you

16 September, 2008

I have also installed SP1 and still have these issues and its driving me insane!

Please help!!

24 September, 2008

Hi Chan/David,

The SP1 beta has to be installed properly, ie, use the tool to uninstall any previous sp1 beta. It also helps to have a decent machine with fast hard drive and memory. On my laptop with 2gigs and 5400rpm drive, it seems to work pretty good. Anyways, good luck and email if you think I can help. You can click on my name and email me using this blog.

24 September, 2008
Joshua Jackson

I did a fresh install of Visual Studio 2008 and SP1 on a fresh install of Vista and this problem is still present. My development machine is a Core2 2.6Ghz quad core machine with 4GB of RAM, and a 10,000 RPM hard drive - system performance is not the issue here.

Visual Studio still has a serious IDE slowdown issue when working in design mode with ASP.NET applications.

7 October, 2008
Joshua Jackson

I just posted about VS2008 SP1 sluggish responses - as I continued to search for possible solutions to the problem, I stumbled on a comment about external resources being loaded in design mode causing the designer to misbehave.

Just for grins, I looked over the project and the only reference I had to an external resource was the Google Analytics javascript at the bottom of the masterpage for my site. I moved this code out to an include and added code to inject it at runtime using a literal control.... presto - my IDE is running at full tilt.

Not sure if this is a fluke, but I know a lot of sites are designed to include references to Google Analytics. It is worth checking out.

7 October, 2008

I downloaded and installed this hotfix:

connect.microsoft.com/.../DownloadDetails.aspx

Since then I haven't expereinced any troubles with intellisense performance on pages with dev express controls.

14 November, 2008

I've been using Visual studio 2008 for a while now with no problems, but recently intellisense has stopped working in all web projects in the aspx pages.

The intellisense shows standard HTML elements, but no <asp:control> elements.

The only thing that's changed is that our PCs have now been connected to a network share, so I thought it could be a permissions issue. However, I changed the permissions using caspol.exe to no avail, and then tried creating the web project in the root of my C:\ and that didn't help either.

4 December, 2008
Nick

In my case it was Google Analytics just as Joshua pointed out.  Runs like a dream now.

11 December, 2008

Any updates/solutions on this. I have downloaded/installed the fix that Ivan has mentioned  above.

Any other fixes that would help ?

5 January, 2009
Ulrich

I am working with VS 2008 SP1 and my first small testproject keeps getting slower and slower during design time.

For example:

I change the (Name) property of a TextEdit Control (DX.8.3) and VS freeces for 30 seconds or so. Everything works correct, but too slow!

Any news to this?

10 January, 2009
Junior

Use context menu to Open With --> Xml Editor. Speed is awesome! =)

The XPath navigation is slowing things down. Is there anyway to disable it?

27 January, 2009
Stuart Clouston

After applying the hotfix, the service pack, the tweaks, etc my VS2008 still ran like a snail in design mode.

I found that the solution in my case was that my VS2008 user profile had been created before VS2008 SP1 was installed and I had selected "General Development" settings at first startup.  I created a second computer account AFTER VS2008 SP1 was applied and this time selected "Web Development" settings on first startup and it performs at an acceptable speed under this login.

16 April, 2009
Nikhil

i have same problam

if any solution then discribe plz

16 June, 2009
vantigate

I downloaded and installed this hotfix.  It fixed my intellisense issue with a vs2005 upgaded project:

connect.microsoft.com/.../DownloadDetails.aspx

6 October, 2009

Hi, I was having really slow VS2008 designer performance issues, it was taking many seconds to do simple updates, and was even worse on heavier pages. It was seriously affecting my productivity even with all the hotfixes installed. I finally tracked it down to some dodgy html tags.

I dont know how this happens, but it would appear that the DevExpress controls sometimes leave '__designer' tags within the HTML code, these seem to upset VS2008 and result in REALLY slow design surface performance. Once I manually removed them from my masterpage and content page, things operated much much quicker.

It might be something to look for if you re still experiencing problems with all the hot fixes installed.

6 January, 2010

It does not seem that there is a solution here? I dont seem to have this problem with [competitor]???

1 February, 2010

@Deon,

Yes, the issue was resolved, you can find the solution here:

community.devexpress.com/.../download-updated-vs2008-hotfix-kb967253.aspx

More VS2008 posts:

http://bit.ly/cnCR2I

1 February, 2010

What is the update for the fix

12 February, 2010

@Bob,

Install the hotfix because it resolves the designer issue:

community.devexpress.com/.../download-updated-vs2008-hotfix-kb967253.aspx

12 February, 2010

Someone referenced this post to answer question "C++ project driving me crazy?"...

1 December, 2010

Is there a solution for VS2010 yet?  I am having the same issue there.

5 December, 2010

Hi Johnathon,

Haven't seen this issue for VS2010 because the hotfix was already rolled into VS2010 before release.

Can you please upload a small sample to support so they can have a closer look?

www.devexpress.com/.../CreateIssue.aspx

6 December, 2010

Hello Guys,

I have the same or similar problem in Visual Studio 2010 Express/Premium.

In Split view saving aspx file takes a long long time. In srce code view only saving is normal.

In Split view is there any rendering Design mode  every time as Save file is clicked ?

Regards

Waldemar

27 February, 2012

Waldemar,

If you're using any DevExpress products then please contact our support team here and they can help you:

www.devexpress.com/.../CreateIssue.aspx

If not, then please contact Microsoft support.

Thanks.

27 February, 2012

Hello Mehul,

Yes, I have been using ASP.NET Suite.

I started read about similar issue in Desing view like below thread

www.devexpress.com/.../B202361.aspx

Regards

Waldemar

28 February, 2012

Waldemar,

I recommend reporting this issue to our support team then:

www.devexpress.com/.../CreateIssue.aspx

Thanks.

28 February, 2012

Please login or register to post comments.