XPO - VistaDB 6, PostgreSQL 12 Support & More (v19.2)

XPO Team Blog
01 November 2019

As you may already know, we released v19.2 last week. In this post, I want to highlight a couple of small, but important additions to our ORM.

VistaDB 6 Support

XPO v19.2.3 supports the latest version of VistaDB 6 with VistaDb6ConnectionProvider. Related Support Tickets: T824999 | T822805 | T828597.

PostgreSQL 12 Support

The new version of this popular open-source database engine was also released this month. XPO will support PostgreSQL 12 in our next update (v19.2.4). Related Support TicketT818996.

Microsoft.Data.SqlClient

Microsoft recommends the new Microsoft.Data.SqlClient instead of System.Data.SqlClient for new projects. The new driver targets both .NET Framework and .NET Core apps. Going forward, support for new SQL Server features will only be implemented in Microsoft.Data.SqlClient.

We already researched this new driver and it seems that XPO will support it without problems. Expect more news from us in coming months.

Please let us know if you already tested the new driver with or without XPO on your own. Thanks.

3 comment(s)
renejdm
renejdm
Thank you for your quick support of VistaDB 6.
3 November, 2019
Gary D
Gary D
Thank you #2 for VistaDB 6.
3 November, 2019
Dennis (DevExpress)
Dennis (DevExpress)

Thank you for using XPO, Guys.

4 November, 2019

Please login or register to post comments.