ASP.NET Core Controls — .NET 6 Is the New Minimum Supported Framework Version in v22.2

News
08 November 2022

In our upcoming major release (v22.2), DevExpress ASP.NET Core Controls will require .NET 6 and Visual Studio 2022 (v17.0) or higher.

Primary motivations behind this decision are security and the end of support for previous .NET versions. According to Microsoft, .NET 6 is a long-term support (LTS) release. This release will be supported until November 12, 2024 (for more information, refer to the following document: .NET and .NET Core Support Policy). Throughout this time frame, you will be able to receive security updates and patches from Microsoft.

This change affects the following UI controls/libraries:

Update your application

To upgrade your application to .NET 6, we recommend that you follow the steps outlined in the following Microsoft guides: 

To help with the transition, we’ll update relevant DevExpress help topics (related to ASP.NET component integration) in the near future. Should you have a question on .NET 6 in the interim, feel free to submit a support ticket via the DevExpress Support Center.

Your Feeback Matters

Free DevExpress Products – Get Your Copy Today

The following free DevExpress product offers remain available. Should you have any questions about the free offers below, please submit a ticket via the DevExpress Support Center at your convenience. We’ll be happy to follow-up.