Bootstrap 4 Support - (v17.2.5)

It’s literally taken us years to do it, but Bootstrap 4 has finally arrived! - Bootstrap Blog

Last week, the Bootstrap team officially released Bootstrap 4 and I'm happy to say that the excellent DevExpress Bootstrap controls for ASP.NET WebForms and ASP.NET Core support this latest Bootstrap release.

I recommend reading the blog post to see what's new and test the new examples. There's also a helpful migrating to v4 guide.

Download Latest Version

The v17.2.5 minor release is now available and it features updated the project templates for our Bootstrap Controls. Download and update your installations.

DevExtreme Support

The DevExtreme team is currently working on updating the DevExtreme themes and the ThemeBuilder tool to support Bootstrap 4. Therefore, you'll see official DevExtreme support for Bootstrap 4 in the upcoming v18.1 major release.

The DevExtreme Reactive controls will have support for Bootstrap 4 in the coming weeks. You can track this pull request for full updates.

Classic ASP.NET/MVC

The classic DevExpress ASP.NET controls that support ASP.NET WebForms and MVC can be used with Bootstrap (up to version 3). And the team is looking into supporting Bootstrap v4 in a future release. However, as I've written before, when using the Bootstrap framework, it's better to use the DevExpress Bootstrap Controls which were specifically written for the Bootstrap framework.


Email: mharry@devexpress.com

Twitter: @mehulharry

4 comment(s)

Could you please clarify the compatibility for the Bootstrap ASP.Net controls?

You said in the first paragraph that they are compatible with version 4.  

But looking at this web page:

www.devexpress.com/.../bootstrap.xml

On the Shipping Versions and Supported Technologies, Bootstrap ASP.NET WebForms Controls: Shipping Versions & Supported Technologies

It says:

Supported Frameworks:

Bootstrap 3

.NET Framework 4.0+

Thank you.

30 March, 2018

@Josue,

Thanks for catching that and yes, they do support Bootstrap 4. We'll update the page soon.

30 March, 2018

When I download the 18.1.4 DevExpress.Web.Bootstrap package it has a dependency on bootstrap (<= 3.3.6 && < 4.0.0)

17 July, 2018

@Jesper, thanks, we'll update it in the (likely) next minor release.

19 July, 2018

Please login or register to post comments.